Logiciel d'analyse de rapport ZHPDiag.
  • Avatar du membre
  • Avatar du membre
  • Avatar du membre
  • Avatar du membre
Avatar du membre
par Le Che
#95536
Hello

Je fais un ZHPDiag. J'ouvre ZHPLite , puis je clique sur charger rapport, je vais chercher le rapport ZHPDiag.txt sur le bureau . Normalement après, jusqu'à présent , je cliquais sur la loupe " analyser le rapport " et l'analyse commençait. je viens de constater que dès qu'on avait charger le rapport celui ci commençait aussitôt à se dérouler( pas le temps de cliquer sur la loupe ) mais l'analyse ne se faisait pas. Aucun résultat. Par contre si je faisais un " copier coller " du rapport ZHPDiag.txt dans le cadre réservé dans ZHPLite, alors dans ces conditions on pouvait cliquer sur la loupe et l'analyse commençait. Fais un test tu comprendras ce que je veux dire ;)
Avatar du membre
par Pierre95
#95544
Bonjour à tous ,

@Ernesto

1ère méthode:

Je fais un ZHPDiag. J'ouvre ZHPLite , puis je clique sur charger rapport, je vais chercher le rapport ZHPDiag.txt sur le bureau . Normalement après, jusqu'à présent , je cliquais sur la loupe " analyser le rapport " et l'analyse commençait. je viens de constater que dès qu'on avait charger le rapport celui ci commençait aussitôt à se dérouler( pas le temps de cliquer sur la loupe ) mais l'analyse ne se faisait pas. Aucun résultat.
Cher Commandante et si tu cliques après sur la loupe " Analyser le rapport " en haut à gauche dès que celui çi a fini de se dérouler ,rien ne se passe ?
Parfois, c'est immédiat, parfois, il faut attendre quelques secondes et il y a un éclair et cela part chez moi
Avatar du membre
par Le Che
#95545
Pierre95 a écrit :
lun. 4 mars 2019 13:42


Cher Commandante et si tu cliques après sur la loupe " Analyser le rapport " en haut à gauche dès que celui çi a fini de se dérouler ,rien ne se passe ?

Oui, ça marche, mais ce n'est pas normal, ou alors Nicolas a modifié quelque chose
#95556
Hello,

Voilà la raison !

A la suite de la demande de Pierre, j'ai du modifier ZHPLite pour qu'il puisses prendre en compte les caractères spéciaux UTF8. J'avais d'ailleurs fait la même modification pour ZHPScript.

Techniquement :
Cette modification à consister à remplacer une fonction interne d'AutoIt "_GUICtrlRichEdit_StreamFromFile" qui gère les flux de données par une fonction perso.
Ma fonction se fait avec une lecture séquentielle de chaque ligne du rapport, ce qui se traduit par un défilement dans la zone d'édition.
Il ne s'agit en aucun cas d'un début d'analyse, laquelle ne démarre qu'en appuyant sur "Analyser le rapport".

A l'avenir, je vais étudier s'il est possible de masquer ce défilement...
Avatar du membre
par Le Che
#95557
Hello

merci pour cette précision
Modifié en dernier par Le Che le mar. 5 mars 2019 08:02, modifié 1 fois.
SUP.Orphan.Compatibility

Hello, C'est nouveau ! Hello ok, je m[…]

Bonsoir Gérard, Comme je peux toujours me […]

validation d'un ZHPScript

Bonsoir, Merci pour l'aide apportée. Voi[…]

Infection suite téléchargement

Bonjour, Bienvenu(e) sur le Forum de Nicolas […]